Showcase Summicron haze!!!

Discussion in 'Leica M and LTM Mount Lens Sample Image Showcase' started by salaso, Jan 8, 2015.

  1. salaso

    salaso New to Leica Place

    6
    Jan 8, 2015
    Hi there,
    Does any body knows how to remove the front element of a summicron 5cm F2 rigid? Im trying to remove it as it seems to have a haze attack on the inner side and I want to clean it, I was looking on google or youtube for info on how to remove it but no luck. I have removed 2 black rings and tryied to get out the first element with a suction thing but its not moving at all, please help :(
     
  2. Brian

    Brian Super Moderator Subscribing Member

    Apr 3, 2013
    • Like Like x 1
  3. salaso

    salaso New to Leica Place

    6
    Jan 8, 2015
    Thanks!!
    So after removing the washer and the retaining ring I just need to pull the element right?
    seems to be extremely Tight :/
     
  4. Brian

    Brian Super Moderator Subscribing Member

    Apr 3, 2013
    That is it- nothing else holding it in. The front element is very tight, was not quite as bad as my E48 90/2 Summicron.

    Report back in if you have any luck. I used a "Barbie Sun Catcher Suction Cup", soft vinyl.
     
  5. salaso

    salaso New to Leica Place

    6
    Jan 8, 2015
    I used a cup with almost the same size of the front element but no luck :(

    DSCF5445.
     
  6. Brian

    Brian Super Moderator Subscribing Member

    Apr 3, 2013
    All I can add- use a smaller cup, some cleaner under it, and pull from one of the sides.

    This element is in too tight, in my opinion. I had one Summicron that I had to bore out the fixture to replace the front element with a new one.
     
  7. salaso

    salaso New to Leica Place

    6
    Jan 8, 2015
    Ill try that and if it doesn't work Ill try with some silicon glue :eek:
     
  8. Brian

    Brian Super Moderator Subscribing Member

    Apr 3, 2013
    I just spent the day making a 1950 J-3, really a 1943 Sonnar, work. Someone converted the Sonnar/J-3 to Leica mount using a ZOMZ J-3 focus mount. They GLUED it in place and never bothered to check the focus, which was WAY, WAY off- by 2m at 5m.

    Acetone and 99% Isopropyl alcohol.
     
  9. salaso

    salaso New to Leica Place

    6
    Jan 8, 2015
    ok this was hard but I could pull out the front element only with some poxipol and a metal stick to pull from it :eek:
     
    • Like Like x 1
  10. Brian

    Brian Super Moderator Subscribing Member

    Apr 3, 2013
    That is extreme! Did the front coating show any marks after getting the poxipol (epoxy) off?
     
  11. salaso

    salaso New to Leica Place

    6
    Jan 8, 2015
    haha yes, from what I can see there is no damage on the coating or the lens. 10 minutes after removing the glass from the body it dropped off by itself from the epoxy, I dont know why but it worked :cool:
     
    • Like Like x 1
  12. Brian

    Brian Super Moderator Subscribing Member

    Apr 3, 2013
    I shall add this to the Bag of Tricks!